How to Solve Http Package Does not Exist ?

· 2 min read
How to Solve Http Package Does not Exist
How to Solve Http Package Does not Exist

Most apps now a day require to fetch data from the internet. Http package provides the simplest way to fetch data from the internet so in this article We will learn about  How to Solve Http Package Does not Exist?

How to Solve Http Package Does not Exist ?

  • It is a clear way to add https to flutter
      • Add this to your package’s pubspec.yaml file:
        dependencies:
          http: ^0.12.0
  • You can install packages from the command line with pub:
$ pub get
  • With Flutter:
    $ flutter packages get
    1. Import it Now in your Dart code, you can use:
      import 'package:http/http.dart';
  • In Android Studio import like this
  • Go to pubspec.yaml
  • Add dependency http: ^0.12.0+2
  • Click on Packages get at the top
    Import
    Import

    If the issue still persists then try the following steps this worked for me.

  • Restart your android studio.
  • Go to flutter Inspector toolbar
  • Click on the Refresh Widget info button.

    Refresh Widget Flutter Agency
    Refresh Widget Flutter Agency

Conclusion:

In this article, we have learned about How to Solve Http Package Does not Exist?

Thanks for Reading!!! Keep Learning.

Do let us know if you need any assistance with Flutter Development?

FlutterAgency.com is our portal Platform dedicated to Flutter Technology and Flutter Developers. The portal is full of cool resources from Flutter like Flutter Widget GuideFlutter ProjectsCode libs and etc.

FlutterAgency.com is one of the most popular online portal dedicated to Flutter Technology and daily thousands of unique visitors come to this portal to enhance their knowledge on Flutter.

Leave a Reply